2.1. Installing MongoEngineΒΆ

To use MongoEngine, you will need to download MongoDB and ensure it is running in an accessible location. You will also need PyMongo to use MongoEngine, but if you install MongoEngine using setuptools, then the dependencies will be handled for you.

MongoEngine is available on PyPI, so to use it you can use pip:

$ pip install mongoengine

Alternatively, if you don’t have setuptools installed, download it from PyPi and run

$ python setup.py install

To use the bleeding-edge version of MongoEngine, you can get the source from GitHub and install it as above:

$ git clone git://github.com/mongoengine/mongoengine
$ cd mongoengine
$ python setup.py install
Read the Docs v: latest
Versions
latest
v0.7.9
v0.6.8
Downloads
HTML
Epub
On Read the Docs
Project Home
Builds

Free document hosting provided by Read the Docs.